Jump to content

Setting up with XenForo


Recommended Posts

Posted (edited)

Excellent. Great to see you around Jay. How’re you doing? 
 

@Charles am I right in thinking that websites are manually approved by Community Hive before they are added to the feed? 

Edited by Lee
  • Like 1
Link to comment
Share on other sites

Just now, Lee said:

Excellent. Great to see you around Jay. How’re you doing? 
 

@Charles am I right in thinking that websites are manually approved by Community Hive before they are added to t(e feed? 

I'm doing good, working on a new project using IPS again.

Hope all is well with you.

  • Like 1
Link to comment
Share on other sites

18 minutes ago, Lee said:

Excellent. Great to see you around Jay. How’re you doing? 
 

@Charles am I right in thinking that websites are manually approved by Community Hive before they are added to the feed? 

There's no approval process for those who follow you directly but there is to show in Discover feed.

  • Like 2
Link to comment
Share on other sites

6 minutes ago, Charles said:

There's no approval process for those who follow you directly but there is to show in Discover feed.

Last question, honest. How long until approval / I can see my community in the discover feed? 

Link to comment
Share on other sites

Most issues are being caused by PHP7. We did not realize that Xenforo still supported PHP7 as PHP itself stopped supporting it back in 2021/2022. We do not even have any internal testing environments to test on PHP7 since it's against our security policy to have it.

Luckily, a few people have volunteered to let us re-work the plugin to work on PHP7 on their servers. We should have an update for you soon!

  • Thanks 1
Link to comment
Share on other sites

1 hour ago, Charles said:

Most issues are being caused by PHP7. We did not realize that Xenforo still supported PHP7 as PHP itself stopped supporting it back in 2021/2022. We do not even have any internal testing environments to test on PHP7 since it's against our security policy to have it.

Luckily, a few people have volunteered to let us re-work the plugin to work on PHP7 on their servers. We should have an update for you soon!

I am running an 8.0 branch. 

Link to comment
Share on other sites

I have a problem, I got an error when I installed, now it says my community is already activated, but it's not, my API keys are empty and I don't see my community in my "Account" area on the communityhive website. Any help is appreciated!

 

community_hive_broken.thumb.png.7ab948a725dd74a856d0b35856959898.png

 

That was the error I got, now when I edit the settings in the Options area, it shows my API boxes empty. Where/how do I get API keys? Thanks!

 

Note: It's telling me my community has already been "Activated" but I didn't 'activate' anything.

Link to comment
Share on other sites

1 hour ago, Charles said:

Everything looks to be working right on your site. Are you seeing problems?

16 hours ago, Lee said:

My error log is starting to fill up with this error: 

 

image.thumb.png.8c87dcf554a59701dddd23c419b3cd18.png

 

 

 

 

 

 

 

Link to comment
Share on other sites

We looked into this but we cannot in good conscience support PHP 7. As PHP 7 is end of life and no longer receiving security updates, it will be inappropriate for us to go down that path. We take security and privacy seriously and just cannot support that approach.

If you are running Community Hive on PHP8 an still having problems, please let us know.

Link to comment
Share on other sites

26 minutes ago, Charles said:

We looked into this but we cannot in good conscience support PHP 7. As PHP 7 is end of life and no longer receiving security updates, it will be inappropriate for us to go down that path. We take security and privacy seriously and just cannot support that approach.

If you are running Community Hive on PHP8 an still having problems, please let us know.

Charles, I am not running PHP 7.x at the time of errors I was running 8.0.30 and now I am running 8.1.x.

Link to comment
Share on other sites

Dumb question.

1. I made a account on Hive (its working, you see)
2. I install the Xenforo Hive-Addon
3. I click at Hive-Ad-on settings on Enabled and save - the keys would be generated, they are all 3 there, OK
image.thumb.png.bd27066be59f5f1a612d99bad4922e72.png
...
and now?
Whats next step for me to complete?

In my Hive account I doesn't see the navigation to setup my xenforo site ready to be connected to Hive:


image.png.b2cc63d84f0211d209129254ad389b25.png
How can I manage my site/sites at hive - there is no menu point for in my account.
What do I wrong?
Or have I just to wait?


Its a little bit confusing. 😉

greetings

Link to comment
Share on other sites

22 hours ago, Charles said:

We will have an update for Xenforo plugin tomorrow.

Sorry for the issues. Xenforo is... different 😀

At least you guys reply to posts. The XenForo staff lacks communication. So far you guys have replied to more posts here than the whole XF Staff did in the past 3 years on their own community. 

  • Like 6
  • Thanks 2
Link to comment
Share on other sites

Updated and still get this install error:

community_hive_broken.thumb.png.d750ba7686f77324101a8542086d7c6f.png

 

When I "enable" it in the admin panel, nothing happens. It's not showing up in my feed on here? How do I get this working?

 

When I click "Community Hive" it gives me an internal server error:

string(21) "Internal Server Error"

Edited by Smokey
Link to comment
Share on other sites

4 minutes ago, Smokey said:

Updated and still get this install error:

community_hive_broken.thumb.png.d750ba7686f77324101a8542086d7c6f.png

 

When I "enable" it in the admin panel, nothing happens. It's not showing up in my feed on here? How do I get this working?

You probably have some leftover bad day from when plugin was not working. Please completely uninstall it and reply to the PM I sent you yesterday 🙂 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy